Back to overview
Degraded

Service Degraded

Feb 19 at 09:10am CST
Affected services
Web Platform
Education Content

Resolved
Feb 19 at 10:20am CST

We have deployed a change which will resolve the issue. Sorry for the inconvenience.

Updated
Feb 19 at 10:00am CST

We have identified the root cause of the issue.

Created
Feb 19 at 09:10am CST

We are noticing a very high load on our database at this time. We are currently looking into the root cause of the problem.